עבור לתוכן
Magic DevHub
Developer

הדפסה לקובץ לאחר הסבה

Recommended Posts

הסבנו מערכת מ 9.4 ל יוניפאס 1.9.

נוצר מצב שכל העברית שמודפסת לקובץ (לא PDF או מדפסת רגילה) יוצאת בסימני שאלה.

לאחר שימוש בפונקציה ANSI2OEM העברית מסתדרת אבל לא באופן מלא ז"א שבתוך העברית יש עדיין סימני שאלה.

בהשוואה מול התוכניות הישנות למול התוכניות החדשות נראה שהתוכניות זהות לחלוטין.

השדות ANSI וב-I/O ההגדרה ל-OEM (בשינוי לא מסתדרת הבעיה).

 

האם יש פתרון פשוט להדפסת עברית לקובץ?

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

אני הבנתי שאתה רוצה שנתונים בקובץ יהיו OEM , נכון ?

בדרך כלל בהסבה מבצעים הסבה של נתונים ל-ANSI , האם עשיתם את זה ?

 

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

כבר בגרסת 9.4 הנתונים עמדו על ANSI.

הנתונים הקיימים כעת ג"כ ANSI.

התוכניות זהות מבחינת הגדרת הנתונים וההדפסה לקובץ.

האם הייתה צריכה להיות התיחסות נוספת בהסבה?

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

אגב ב XPA 3.1  ExternalCodePage השתנה מ1252 ל 1255 אצלנו... 

נערך היום על-ידי romang

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים
לפני ב-11/3/2016 at 11:12 Developer אמר:

כבר בגרסת 9.4 הנתונים עמדו על ANSI.

הנתונים הקיימים כעת ג"כ ANSI.

התוכניות זהות מבחינת הגדרת הנתונים וההדפסה לקובץ.

האם הייתה צריכה להיות התיחסות נוספת בהסבה?

מול איזה DATABASE אתה עובד? 

האם בוצע הסבה ל גם לנתונים עצמם ולא רק בהגדרה של מג'יק? 

 

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

בסיס הנתונים של (פרוויסיב ISAM) בטריב.

אינני זוכרת שהיתה הסבה מיוחדת של הנתונים מ-OEM ל-ANSI או להיפך.

בגרסת 9.4 הנתונים תפקדו מצוין עם אותן הגדרות.

בגרסת יוניפאס 1.9 העברית בהדפסה לקובץ יוצאת בסימני שאלה.

בנתיים מההצעות שהועלו כאן ומנסיונות נוספים לא נגעתי לפתרון מלא.

מה שעזר באופן חלקי זו הדפסה של הנתונים ע"י הפונקציה ANSI2OEM עם FLIP אבל עדיין המילים מלוות בסימני שאלה.

לדוגמא: במקום שוקרון שלמה בקובץ מודפס שוקרון ש??ה.

נשמע לי שזה משהו פשוט שכבר מרוב התעסקות התבלבלתי לגמרי...

 

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

externalcodepage בדקת?

1) תשמור קובץ בצד כגיבוי

2) תרוץ על טבלה ותעדכן את השדה ב

OEM2ANSI של אותו שדה

 

 

נערך היום על-ידי romang
3) ההגדרה I/O לשנות גם ך ANSI ולוודא שברמת השדות מוגדר ANSI

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

הפתרון...

בהגדרת ה-I/O שיניתי את הויזואלי ל- לא.

מחקתי את המבנה, בניתי מחדש, חזר לשפיות.

רומן ואריאל, אלפי תודות על כל האכפתיות והעלאת הרעיונות המגוונים!

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

התחבר או הרשם על מנת להגיב.

עליך להיות משתמש רשום על מנת להגיב

צור חשבון

צור חשבון חדש בקהילה בקלי קלות.

רישום חשבון חדש

התחבר

משתמש קיים? התחבר.

התחבר עכשיו

×