עבור לתוכן
Magic DevHub
arikm

נושאים לכנס הקרוב

Recommended Posts

חברים,

אנחנו מעוניים לקיים כנס מפתחים בסביבות יוני יולי

יש את הנושאים הקבועים כמו בכל כנס

אני מעוניין לשמוע אילו נושאים מעניינים אותכם שתרצו שנתייחס אליהם בכנס

אריק

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

היי אריק

בתחום UI נראית מגמה של מעבר מארכיטקטורת WINFORMS ל- WPF. האם ואיך ישפיע הנושא על קו המוצר העתידי של מג'יק.

דרך אגב יולי נראה לי זמן לא הכי מומלץ...

תודה ולהתראות

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

הי גדי,
תודה, הכנס יהיה קרוב לוודאי ביוני

אשמח לעוד רעיונות

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

אין עדיין תאריך סגור, דחינו בגלל החופשה הקרבה

זה מתוכנן לחודש ספטמבר לפני החגים

השנה החגים יוצאים מאוחר

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

היי אריק.

אשמח אם תתייחסו לאי-בהירות מסוים שיש לי בנוגע לתמיכת XPA ב- DotNet Framework בגרסאות מעל 2.0.

נתקלתי באיחור מה בתיעוד המגבלה בקובץ העזרה, ואני רואה אפילו בתיעוד של XPA 2.5 שהתמיכה היא בגרסה 2.0 בלבד.

בפועל אני משתמש זה זמן-מה ב-Assemblies מגרסה 4.0 ולא נתקלתי עד כה בבעיה. הדילמה יותר משמעותית עם התקנת מוצרי צד שלישי, אשר מגיעים לעתים קרובות ב- 2 גרסאות. FW2 ו-FW4. גם כאן העדפתי, מטבע הדברים, לעשות שימוש בגרסה החדשה יותר, ולא נתקלתי בבעיות.

אשמח אם תוכלו להתייחס מעט להבדלים בין הגרסאות ולתת דגשים בנושא האינטראקציה מול XPA, ואם יש מקום לחשוש מבעיות תאימות שעלולות לצוץ בהמשך , או שעצם היכולת לטעון את ה- ASSEMBLIES החדשים יותר די בו כדי לתת אינדיקציה שהם מתאימים לעבודה מול XPA.

תודה רבה ולהתראות.

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

הי גדי,

ברשותך אסיר את כל אי הבהירות.

Magic xpa תומך ב- NET framework. מגרסא 2.0 וצפונה. משמע אנחנו תומכים גם בגרסא 4.5.

הכוונה היא הגרסא הבסיסית ביותר הנתמכת היא 2.0.

בדיוק כמו במערכות הפעלה, XP ומעלה.

אין הגיון לא לתמוך בגרסאות חדשות. הפוך כן!

אני מקוה שזה מבהיר את הנושא

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

היי אריק,

הסיבה שציינתי שיש אי-בהירות היא שבתיעוד של XPA, לרבות גרסה 2.5 שיצאה זה עתה, מופיע במסך העזרה שכותרתו:
.NET Assembly Properties

הטקסט הבא בתחתית המסך בהערה מודגשת:
V4.0 .NET assemblies are not supported.

יכול להיות שמדובר בטעות ויכול להיות שאני לא מבין נכון, בכל מקרה הבהרת בצורה ברורה את הנושא ועל כך תודה רבה.

דרך אגב, בנושא תמיכה בגרסאות X וצפונה, המינוח שהשתמשת בו שהגרסא הבסיסית ביותר היא 2.0 לא עובר היטב לעולם מערכות ההפעלה ובסיס הנתונים. תמיכת המוצר בגרסאות חדשות של מערכת הפעלה או בסיס נתונים ממש אינה מובנת מאליה, ובטח לא ניתן לצפות שזה יהיה מובן מאליו בכל מה שנוגע ל dot net framework.

להתראות בכנס (יש תאריך?)

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

בגרסאות נתמכות מג'יק תמיד מספקת תמיכה במערכות הפעלה ובסיסי נתונים האחרונים (מופי בתיעוד אילו מערכות הפעלה ובסיסי נתונים)
לא הגיוני שחברת מג'יק לא תתמוך בגרסאות אחרונות של סביבות הריצה המקובלת.
אגב תמיכה ב NET. זה לא רק פ'יצק, מדובר בסביבת ההפעלה החדשה של מג'יק, לכן אנחנו חייבים תאימות.

לגבי מועד, עובדים על זה אני מניח שאוקטובר נובמבר

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

התחבר או הרשם על מנת להגיב.

עליך להיות משתמש רשום על מנת להגיב

צור חשבון

צור חשבון חדש בקהילה בקלי קלות.

רישום חשבון חדש

התחבר

משתמש קיים? התחבר.

התחבר עכשיו

×