עבור לתוכן
Magic DevHub
eyal_barouk

התקנת RIA על שני שרתים נפרדים

Recommended Posts

שלום,

uniPaaS 1.9

אני מנסה להתקין RIA על שרת WEB ועל שרת אפליקצייה בנפרד. שרת ה WEB פתוח לאינטרנט ושרת האפליקצייה יושב ברשת הפנימית של הארגון. לצורך הפיתוח, כל הפורטים פתוחים כרגע בין השרתים. אני משתמש בפורט 5000

בשרת ה WEB התקנתי uniPaas כשרת WEB , ה IIS מוגדר ואני מקבל את דף הכניסה: publish.html

בשרת האפליקצייה מותקן ורץ הדמו של Getting Started with uniPaaS Rich Client יחד עם הברוקר.

כשאני לוחץ על Start אני כל הזמן מקבל שגיאה 104 There are no enterprise servers available

mywebserver.com --> 192.168..../5000

האם קיים מדריך מפורט כיצד לעשות זאת, או מישהו שיהיה מוכן לעזור לי עם ההתקנה?

בתודה מראש,

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

מה שאליך לעשות זה בקובץ MGREQ.ini שיושב בשרת WEB להגיד לו שיפנה לIP/BROKER PORT לברוקר שיושב בשרת אפליקציה

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים
שלום,
תודה על התשובה.
בקובץ MGREQ.ini בשרת WEB מוגדר לי
MessagingServer=192.168.10.202/5000
בשרת האפליקצייה מוגדר
BrokerPort=192.168.10.202/5000
ואני גם רואה שהברוקר עובד ומצביע על האפליקציה הנכונה.

אני עדיין מקבל את אותה השגיאה.
תודה

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

כאשר אתה מבצע פניה משרת WEB ל שרת אפליקציה האם אתה רואה ב BROKER MONITOR שמתבצעת פניה?

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

כן, אני רואה במוניטור שמתבצעת פנייה.

ואני מקבל ב mrb_event.log

את השגיאה הבאה:

MGERROR -109 ERR-CNCT_REFUSED_RT

מה זה אומר?

תודה!

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

זה מה שכתוב בעזרה

Connection problems between requesters and enterprise servers.

Check the firewall settings between the client and server computers, host name resolving, etc.

You can view the Broker monitor to view the status of the enterprise servers. Ping the host name and ip address of the assigned enterprise server.

Verify that the engine is alive; for example, in the Task Manager, according to the PID displayed in the broker’S status window. Call this engine from A command line requester, in order to isolate the source of the problem. (Connections are created and destroyed for each request of the command line requester.)

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים
כיביתי את Windows Firewall בשרת האפליקציה שבתוך רשת הארגון והכל עובד.
נוסיף Rule בהמשך.
המון תודה!

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

התחבר או הרשם על מנת להגיב.

עליך להיות משתמש רשום על מנת להגיב

צור חשבון

צור חשבון חדש בקהילה בקלי קלות.

רישום חשבון חדש

התחבר

משתמש קיים? התחבר.

התחבר עכשיו

×