עבור לתוכן
Magic DevHub
gadito

בעיות MAGIC10 SP2

Recommended Posts

נראה לי חשוב להציג לכם את הבעיות שבהת נתקלתי  ( ופתרונם .. )

1. מסד נתונים אורקל לא נטען - לא נמצאה סיבה מיידית, נפתר כאשר החזרתי את הרכיב
MGORA.DLL מגרסה קודמת  (SP1)
2. אין עברית ב ODBC   - מופיע גיבריש ! - נפתר כאשר החזרתי את הרכיב MGODBC.DLL מגרסה קודמת.
3. לא ניתן לעבוד(לפתח) יותר במקביל ללא הגדרת ניהול תצורה .
חבל מאוד במקום לפתור את העבודה במקביל  החליטו לבצע חסימה - אני מקווה שלפחות לא ידפקו יותר תוכניות כמו ב SP1.

4.היה מי שדיווח על בעיות של יצוא ויבוא , לא נתקלתי בזה - אצלי זה עובד !.

זה לבנתיים ..

אם למשהו יש רעיונות אחרים כיצד יש לפתור את הנושאים הללו או שנתקל בבעיות אחרות אשמח לדעת .

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

אצלי בגרסה הנ"ל, יבוא יצוא, לא עובד חד משמעית. (גם יבוא ויצוא מאותו פרויקט לאותו פרויקט)

אין לי מושג למה, וכרגע אין לי קריאות פתוחות מול מג'יק.

ישי

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

דווקא לי יש קריאות ...

אבל לא בא לי לפתוח קריאות  ..

בSP הקודם הם העבידו אותי כהוגן ...

(הגדרת מחולל דוחות ברשת , התקנה ב 2003 SERVER   , ניהול תצורה ועוד.. )

אני לא עובד אצלהם ..

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

quote user="gadito"דווקא לי יש קריאות ...

אבל לא בא לי לפתוח קריאות  ..

בSP הקודם הם העבידו אותי כהוגן ...

(הגדרת מחולל דוחות ברשת , התקנה ב 2003 SERVER   , ניהול תצורה ועוד.. Wink

אני לא עובד אצלהם ..

/quote

גדי,

מטרת התמיכה אינה "להעביד" אותך אלא לשחזר את הבעיות עליהן אתה מדווח ע"מ לפתור אותם (בשביל את עושים תמיכה לא?)

בברכה

אריק

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

אריק ,

תודה על הערה .

בכל מקרה פתחתי קריאות ...

אני אדווח מה קורה , ונראה ?

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

הבטחתי שאחזור , התשובה של מגיק (ביינתים )

שכיוון שאני עובד עם אורקל 8  , ומגיק 10 לא תומך יותר בבסיס זה ! אז הם לא יכולים לעזור ..

(תשובה מרגיזה לכל הדעות , מה שלא מסביר כיצד זה עבד ב SP1 ! . )

שאלתי היא :

האם יש למשהו נסיון דומה ?

תודה

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים
8-) אני עוד יותר עתיק ממך ואנחנו עובדים עם אורקל 7.
עד גרסה 9.4 עובד ללא בעיות כבר בגרסה 10 SP1 זה לא עבד וכמובן קיבלתי תשובה כמוך ממג'יק.
ניסיתי לעבוד ב ODBC לאורקל וזה עבד (:o בד"כ). אין לי מושג מה המשמעות מבחינת ביצועים וכד'.

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

יש משמעות של ביצועים במיוחד במסכי אונליין  ..

ובדוחות לא SQL.

כמו כן יש שינויים בסינטקס ...

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

quote user="gadito"הבטחתי שאחזור , התשובה של מגיק (ביינתים )

שכיוון שאני עובד עם אורקל 8  , ומגיק 10 לא תומך יותר בבסיס זה ! אז הם לא יכולים לעזור ..

(תשובה מרגיזה לכל הדעות , מה שלא מסביר כיצד זה עבד ב SP1 ! . )

שאלתי היא :

האם יש למשהו נסיון דומה ?

תודה

/quote

חברים,

בהמשך להודעה של גדי בנושא תמיכה באורקל 8, אני מבקש אחת ולתמיד להבהיר נקודה חשובה!!!

כשמג'יק אומרת שמוצר מסויים של ספק כלשהו (במקרה זה הדוגמא אורקל 8) אינה נתמכת ע"י גרסא חדשה של מג'יק (במקרה זה eDeveloper v10.1 sp2) אזי הכוונה:

להלן הגדרת המושג "תמיכה" לפיי מג'יק (וכפי שמקובל בתעשיה בכלל) שחברת מג'יק החליטה להפסיק לתמוך מבחינת בדיקות תאימות של מחלקת ה-QC, זה עוד אומר שאנו לא מתעדים וכמו כן יותר לא ניצבור ידע בנושא.

זה לא אומר ששני המוצרים לא יעבדו בהכרח ביחד!!!

לכן קורה הרבה פעמים שאתם מצליחים לעבוד עם גרסאות לא נתמכות (ראו מג'יק DOS על XP כנגד כל הסיכויים) ולמא מבינים איך מג'יק מודיעה שהמוצר לא נתמך.

מדוע זה קורה- מג'יק רוצה (בדיוק כמוכם) לספק מוצר עדכני, חדשני עם יכולות טכנטלוגיות מתקדמות, אחד המחירים הנו לוותר על טכנולוגיות ישנות שברוב המקרים גם הספק של המוצר מודיע על הפסקת תמיכה במוצר (ראה ערך בטריב 6.15, חלונות 98 ועוד). מג'יק כידוע לכם (אם לא, אני מחדש) נמצאת בהסכמי ידע עם ספקי צד שלישי (כגון מיקרוסופט, פריוויסיב ועוד) ולעיתים נעזרת בהם כאשר מדובר במוצרים שלהם. לא ייתכן שאנו ניתן תמיכה על מוצרים שהספקים מצד שלישי מסרבים לתמוך!

בכל מקרה כל שותף או לקוח הנמצא בהסכם תמיכה מול מרכז התמיכה הבינלאומית, יקבל תמיכה (סיוע טכני ראשוני) גם במוצרים לא נתמכים אולם רק במידה והידע קיים אצלנו ולא דורש כל כניסה לקוד המקור של eDeveloper.

בקיצור, אני מקווה שהצלחתי להבהיר את ההבדלים.

חג אביב שמח

אריק מיפנו

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים
כמובן כל מה שאריק כותב נכון וקשה מאוד להתווכח איתו אבל...
  1. <li>מג'יק תמיד יוחד בקלות בה ניתן לעבור מגרסה לגרסה. בגרסאות  עד 9.4 (כולל) יצוא בגרסה הישנה יבוא בגרסה חדשה והישום עובד. אפילו המעבר מגרסאות DOS לגרסת GUI היה יחסית די פשוט. נכון היה צריך לשפר המסכים אבל הלוגיקה, הקישור לבסיסי נתונים ומשימות ה Batch עבדו ללא בעיות. בגרסה 10 ההגירה קצת יותר מסובכת כולל נושא בסיסי נתונים.<li>אצלי ואני מאמין שאינני יחיד חלק מהישומים במג'יק מתקשרים לבסיסי נתונים של ישומים אחרים אשר עובדים בגרסאות שונות. אין לנו שליטה על ישומים אלו ולא תמיד ישנה אופציה להחליפם ביחוד שהם עובדים לשביעות רצון המשתמשים. הדבר גם מייקר ומסבך את כל נושא השידרוג.<li>מבחינת המשתמש קל לשכנע לשדרג הישום לגירסת מג'יק חדשה. הרבה יותר קשה לשכנעו לשדרג בסיס נתונים. בעוד ששידרוג הגרסה הוא כמעט שקוף מבחינתו שידרוג בסיס הנתונים הוא הרבה יותר מסובך וכרוך גם בבעיות טכניות יותר מסובכות. לפעמים צריך גם להחליף חומרה, יכול להיות שצריך להשבית המערכת כחלק מההסבה, לפעמים צריך לעבוד במקביל כדי להבטיח אמינות ותקינות הנתונים.<li>אינני יודע במה זה כרוך אבל לדעתי פיתרון פשוט היה לאפשר ל Gateway's שעבדו בגרסאות קודמות יעבדו גם בגרסה 10 ואז היו מבצעים הרבה יותר הסבות.
    <li>לדעתי המגבלות בנושא בסיס נתונים ימנעו הרבה הסבות לגרסה 10 וישומים ימשיכו לעבוד בגרסאות קודמות (דרך אגב שלא תהיה אי הבנה גרסה 9.4 היא מצויינת). אני חושב שהמטרה הלגיטימית של מג'יק כחברה מסחרית הוא להשיא את רווחיה וזאת גם ע"י מכירת רשיונות לגרסה 10. ההחלטה לא לתמוך לאחור בחלק מבסיסי הנתונים תפגע במעבר לגרסה 10 וכמובן גם בהכנסות של מג'יק.

:D חג שמח

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

רק הערה לגביי הODBC בגירסא 7 מדובר בהאטה של 30% (ומנסיון שלי.. זה גם יכול להיות אפילו יותר ההערה מתייחסת בעיקר לגביי הכניסה לDB עצמו שיכולה להגיע לחצי דקה ואפילו יותר.), לגביי אורקל 10 הם טוענים שאין הבדל משמעותי בין חיבור ישיר וחיבור של ODBC ובאמת שלא הרגשתי הבדל.

אגב, גם אנחנו משדרגים עכשיו מאורקל 7 ל-10 זה לא נושא כ"כ מסובך, וחבל לוותר עליו (ללא קשר לנושא התמיכה).

-עידו

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

quote user="ortal1993ltd"

כמובן כל מה שאריק כותב נכון וקשה מאוד להתווכח איתו אבל...

  1. <li>מג'יק תמיד יוחד בקלות בה ניתן לעבור מגרסה לגרסה. בגרסאות  עד 9.4 (כולל) יצוא בגרסה הישנה יבוא בגרסה חדשה והישום עובד. אפילו המעבר מגרסאות DOS לגרסת GUI היה יחסית די פשוט. נכון היה צריך לשפר המסכים אבל הלוגיקה, הקישור לבסיסי נתונים ומשימות ה Batch עבדו ללא בעיות. בגרסה 10 ההגירה קצת יותר מסובכת כולל נושא בסיסי נתונים.<li>אצלי ואני מאמין שאינני יחיד חלק מהישומים במג'יק מתקשרים לבסיסי נתונים של ישומים אחרים אשר עובדים בגרסאות שונות. אין לנו שליטה על ישומים אלו ולא תמיד ישנה אופציה להחליפם ביחוד שהם עובדים לשביעות רצון המשתמשים. הדבר גם מייקר ומסבך את כל נושא השידרוג.<li>מבחינת המשתמש קל לשכנע לשדרג הישום לגירסת מג'יק חדשה. הרבה יותר קשה לשכנעו לשדרג בסיס נתונים. בעוד ששידרוג הגרסה הוא כמעט שקוף מבחינתו שידרוג בסיס הנתונים הוא הרבה יותר מסובך וכרוך גם בבעיות טכניות יותר מסובכות. לפעמים צריך גם להחליף חומרה, יכול להיות שצריך להשבית המערכת כחלק מההסבה, לפעמים צריך לעבוד במקביל כדי להבטיח אמינות ותקינות הנתונים.<li>אינני יודע במה זה כרוך אבל לדעתי פיתרון פשוט היה לאפשר ל Gateway's שעבדו בגרסאות קודמות יעבדו גם בגרסה 10 ואז היו מבצעים הרבה יותר הסבות.

<li>לדעתי המגבלות בנושא בסיס נתונים ימנעו הרבה הסבות לגרסה 10 וישומים ימשיכו לעבוד בגרסאות קודמות (דרך אגב שלא תהיה אי הבנה גרסה 9.4 היא מצויינת). אני חושב שהמטרה הלגיטימית של מג'יק כחברה מסחרית הוא להשיא את רווחיה וזאת גם ע"י מכירת רשיונות לגרסה 10. ההחלטה לא לתמוך לאחור בחלק מבסיסי הנתונים תפגע במעבר לגרסה 10 וכמובן גם בהכנסות של מג'יק.

Big Smile חג שמח

/quote

הי בני

הנושא רחב ותמיד יעמוד הקונפליקט הקטן בין הטכנולוגיה לתמיכה בגרסאות ישנות וזו עובדה שנצטרך להשלים איתה.

רק לסגור נקודה קטנה, גם מג'יק הייתה שמחה להעניק תמיכה (ברמת הקוד) לגרסאות ישנות של מוצרי צד שלישי (כגון בסיסי נתונים ומערכות הפעלה) אולם עליכם לזכור שמעבר לזה שהחברה המפתחת כבר לא תומכת במוצר שלה יש קושי נוסף של תאימות טכנולוגית שעליו קשה מאד לגשר, לדוגמא: העדר תמיכה של eDeveloper v10 על חלונות 98, eDeveloper v10 מבוסס unicode חלונות 98 לא! השאלה הנשאלת האם לא לעבור ל - unicode בגלל חלונות 98? . זו דוגמא מצויינת של קונפליקט טכנולוגי משמעותי

בקיצור, ברגע שנשלים עם העובדה שלקידמה טכנולוגית יש גם מגרעות יהיה לנו יותר קל להנות מהמוצרים החדשים. וכן, אני בהחלט מזדהה עם בתי התוכנה שלא קל להם להסביר ללקוחותיהם את הקונפליקט הטכנולוגי, כמו שלי לא קל להעביר לכם את המסר :)

בברכה

אריק מיפנו

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

עדכון מהשטח ...

1. הבעיה בODBC (עברית גיבריש .. ) : נמסר לי שהבעיה הייתה ב SP  הקודם  (העברית נרשמה

   ביוניקוד במקום ANSI ועתה הם תקנו את זה( SP2 ) אז רואים גיבריש ( יש לשנות לשדות מסוג UNICODE במילון קבצים כדי שיהיה תואם למה שהוזן ב SP1  )

2. עוד בעיית יוניקוד : כתיבה לrequester   תמיד יוצא יוניקוד ( לא משנה מה בוחרים ... )

אשמח למידע נוסף ....

שתף אשכול


קישור ישיר להודעה
שתף באתרים אחרים

התחבר או הרשם על מנת להגיב.

עליך להיות משתמש רשום על מנת להגיב

צור חשבון

צור חשבון חדש בקהילה בקלי קלות.

רישום חשבון חדש

התחבר

משתמש קיים? התחבר.

התחבר עכשיו

×